Topic: Ubuntu Server 11.04 + Proxy Lusca

Para mastah, Bantuin ane dong. Ane butuh pencerahan. Rencananya ane mau buat ubuntu server 11.04 + Proxy Lusca buat warnet ane.
Bahan bahan :
Dual Core
HD 60 GB
RAM 1GB.

Yang jadi pertanyaan ane :
1. Berapakah pembagian HDnya dan apa ajah step nya ( /home , swap dll ) ?
2. Konfigurasi nya gimana ? ( IP modem 192.168.1.1 ) dan berapakah untuk ip ethernet ubuntu server. ( ane pake 2 ethernet )
3. adakah yang punya squid.conf dan storeurl.pl yang mantabs. Karena aku liat warnet orang speed nya sampai 70 MB padahal dia pake speedy yang 1 Mb.

Mohon dengan sangat bantuan dari rekan-rekan dan para mastah sekalian. Pliiisssssssss

Re: Ubuntu Server 11.04 + Proxy Lusca

SQUID PROXY DENGAN UBUNTU SERVER 11.04 32/64 BIT

Tutorial ini sebagai pengganti tutorial sebelumnya yang tidak terselesaikan.

Hidupkan PC Calon Proxy Server
Masukkan ‘CD Ubuntu Server’ Ke CDROM
Booting dari CDROM
Pilih language English, Enter
Pilih Install Ubuntu Server, Enter
Tekan enter pada ‘Choose Language’ English
Pilih United States
‘Detect Keyboard Layout Pilih ‘No’
Pada Ubuntu ‘Installer Main Menu’ pilih USA
Pada ‘Keyboard Layout’ Pilih USA
Pilih ‘Continue’ pada ‘Configure The Network’
Pilih ‘Configure Network Manually’
Isi IP Address dengan 192.168.11.11 pilih ‘Continue’, lalu tekan Enter
Netmask 255.255.255.0 pilih ‘Continue’, lalu Enter
Pada Gateway sudah terdapat angka ‘192.168.11.1’, biarkan saja terus Tab Pilih ‘Continue’
Pada Name Server Addresses sudah terdapat angka ‘192.168.11.1’ abaikan dan Tab pilih ‘Continue’, lalu enter
Hotsname diisi dengan : anjelanet (terserah anda) terus pilih continue enter
Domain Name: kosongkan saja, pilih ‘Continue’ dan tekan enter
Pada pilihan ‘Configure The Clock’ pilih ‘Select From Worldwide List’ terus cari Jakarta, lalu tekan Enter
Pada menu ‘Partition Disk’ pilih ‘Manually’
(Penulis menggunakan 2 Harddisk 250 GB & 500 GB 7200 RPM, RAM 2 GB PC6400, HDD 500 GB dipersiapkan untuk men-cache Video Streaming & MP3. Jika HDD & RAM anda berbeda sesuaikan dengan kebutuhan, Pola Partition Nomor 1 & 3 tutorial ini mohon tidak di ubah, cukup penyesuaian pada option RAM saja)
Selanjutnya Jika menggunakan Harddisk bekas pakai, Langkahnya kita hapus partisi yang ada terlebih dahulu. Pilih Directory Partition yang akan dihapus, tekan enter dan pilih Delete The Partition (ULANGI PERINTAH INI UNTUK SEMUA PARTISI YG TERSISA).
Jika telah selesai pilih ‘Guided Partitioning’, kemudian pilih ‘Manually’ arahkan pada FREE SPACE. (UNTUK HARDDISK KOSONG LANGSUNG KE LANGKAH INI).
1. Arahkan ke FREE SPACE HDD1 Pilih Create New Partition, Enter
- Besar Partition I adalah 256 MB, Jadikan sebesar itu. Pilih Continue, Enter (Usahakan untuk tidak merubah besaran Partisi Harddisk ini)
- Pilih Primary, Enter
- Pilih Beginning, Enter
- Pada pilihan ‘Use As’ = Ext4, Enter
- Jika muncul option ‘Format The Partition’ tekan enter untuk memilih ‘Yes, Format it’
- Mount point = /boot
- Mount options pilih ‘Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard
- Bootable flag = on
- Pilih ‘Done Setting Up The Partition’
2. Arahkan ke FREE SPACE HDD1 Pilih Create New Partition, Enter
- Besar Partition II adalah 30 GB (Sesuaikan kapasitas HDD anda, minimal 10 GB)
- Pilih Primary, Enter
- Pilih Beginning, Enter
- Pada pilihan ‘Use As’ = Ext4
- Jika muncul option ‘Format The Partition’ tekan enter untuk memilih ‘Yes, Format it’
- Mount point = /
- Mount options pilih ‘Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard
- Pilih ‘Done Setting Up The Partition’




3. Arahkan ke FREE SPACE HDD1 Pilih Create New Partition, Enter
- Besaran Partisi III adalah 4 GB (RAM 2 GB)
(Untuk RAM 1 GB Isikan Partisi III sebesar 2 GB. Rumus = RAM x 2 = Besar Partisi SWAP AREA)
- Pilih Primary, Enter
- Pilih Beginning, Enter
- Pada pilihan ‘Use As’ = Swap Area
- Pilih ‘Done Setting Up The Partition’
4. Arahkan ke FREE SPACE HDD1 Pilih Create New Partition, Enter
- Besar Partition IV adalah keseluruhan sisa HDD 1 yang masih FREE SPACE (dalam hal ini Free Space HDD 1 saya 215,8 GB)
- Pilih Primary, Enter
- Jika muncul option ‘Format The Partition’ tekan enter untuk memilih ‘Yes, Format it’
- Pada pilihan ‘Use As’ untuk Ubuntu Server 32/Bit = ReiserFS, untuk Ubuntu Server 64/Bit Pada pilihan ‘Use As’ = BtrFS
- Pada Mount point = Enter dan pilih Manually, ‘/home ubah menjadi /cache1’
- Mount options untuk Ubuntu Server 32/Bit pilih ‘Notail & Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard,, untuk Ubuntu Server 64/Bit Mount options pilih ‘Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard.
- Pilih ‘Done Setting Up The Partition’

(PERHATIAN : JIKA MENGGUNAKAN 1 HARDDISK, ABAIKAN LANGKAH 5 & 6 BERIKUT INI)

5. Arahkan ke FREE SPACE HDD2 Create New Partition, Enter
- Besar Partition V adalah 300 GB (Sesuaikan kapasitas HDD anda)
- Pilih Primary, Enter
- Pada pilihan ‘Use As’ untuk Ubuntu Server 32/Bit = ReiserFS, untuk Ubuntu Server 64/Bit Pada pilihan ‘Use As’ = BtrFS
- Jika muncul option ‘Format The Partition’ tekan enter untuk memilih ‘Yes, Format it’
- Pada Mount point = Enter dan pilih Manually, ‘/home ubah menjadi /cache2’
- Mount options untuk Ubuntu Server 32/Bit pilih ‘Notail &Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard, untuk Ubuntu Server 64/Bit Mount options pilih ‘Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard.
- Pilih ‘Done Setting Up The Partition’
6. Arahkan ke FREE SPACE HDD2 Create New Partition, Enter
- Besar Partition V adalah 200 GB (Sesuaikan kapasitas HDD anda)
- Pilih Primary, Enter
- Pada pilihan ‘Use As’ untuk Ubuntu Server 32/Bit = ReiserFS, untuk Ubuntu Server 64/Bit Pada pilihan ‘Use As’ = BtrFS
- Jika muncul option ‘Format The Partition’ tekan enter untuk memilih ‘Yes, Format it’
- Pada Mount point = Enter dan pilih Manually, ‘/home ubah menjadi /cache3’
- Mount options untuk Ubuntu Server 32/Bit pilih ‘Notail &Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard, untuk Ubuntu Server 64/Bit Mount options pilih ‘Noatime’ dengan menekan tombol ‘SPACE’ pada keyboard.
- Pilih ‘Done Setting Up The Partition’

Pilih Finish Partitioning And Write Changes To Disk, tekan Enter
Pada pilihan Write The Changes To Disk pilih Yes, tekan Enter
Pada Full Name For The New User isi dg anjelanet, pilih continue & tekan Enter
Pada Username For Your Account isi dg anjelanet, terus continue & tekan Enter
Pada a password For The New User isi dg anjelanet, terus continue & tekan Enter
Pada Re-Enter Password To Verify isi dg anjelanet, terus continue & tekan Enter
Jika muncul pilihan Use Weak Password pilih Yes, tekan Enter
Pada pilihan Encrypt Your Home Directory pilih ‘No’, tekan Enter
Pada pilihan HTTP Proxy Information dikosongkan saja, pilih Continues, tekan Enter
Pada saat ‘Configuration apt’ mencapai 23% tekan enter, juga pada 72% tekan Enter
Pada saat pilihan updating pilih ‘No Automatic Update’
Pada Choose Software To Install pilih ‘OpenSSH Server’ dengan menekan tombol ‘SPACE’ pada keyboard, selanjutnya pilih Continues, tekan Enter
Pada Pilihan ‘Install GRUB Loader’ pilih Yes
Pada saat ‘Ejecting CD Ubuntu Server Installer’ ambil CD-nya tutup kembali CDROM dan pilih pilih Continues

‘FINISH THE INSTALLATION & CPU ON PROCEED REBOOT, DON’T TOUCH ANYTHING’
‘NOW WAKE UP… PROXY SERVER UBUNTU IS READY FOR NEXT STAGE’

Login pada Ubuntu Server (Isikan sesuai User & Password anda)
- Login as : anjelanet
- Password : anjelanet
Untuk proses agar bisa Login di @root :
- Ketikan perintah : sudo su – dan tekan enter
- Isikan Password : anjelanet
- Ketikan perintah : passwd dan tekan enter
- Isikan Password Baru : anjelanet
- Isikan kembali Password Baru : anjelanet
- Reboot PC dengan mengetikan perintah = reboot –h now
Hubungkan Kabel UTP atau Kabel LAN dari PC ke Routerboard (Mikrotik) pada ether3 (terserah sisa Port Mikrotik anda). Jenis Kabel LAN bisa Type ‘Straight’ atau Type ‘Cross’, terserah anda.
Pada Mikrotik masuk dengan Winbox pilih interface ether3 (terserah sisa Port Mikrotik anda) ganti nama ‘ether3’ menjadi ‘Proxy’ dan pilih ‘OK’
Pilih Terminal dan masukkan script berikut :

/ip address
add address=192.168.11.1/24 network=192.168.11.0 broadcast=192.168.11.255 interface= Proxy

Cek Koneksi PC Proxy server dengan Mikrotik dari Terminal Mikrotik, ketikan perintah berikut :

Ping 8.8.8.8

Jika berjalan dengan baik Ping - nya, PC Proxy server dengan Mikrotik telah terhubung dengan baik.
PERSIAPAN Instalasi Squid download dahulu dari Web Browser File squid.conf, sysctl.conf, squid, storeurl DISINI.
Cek terlebih dahulu Type dan Komponen PC Proxy Server anda, selanjutnya masuk ke http://en.gentoo-wiki.com/wiki/Safe_Cflags, tentukan CHOST, CFLAGS & CXXFLAGS PC Proxy Server anda untuk proses ‘Compile’ . Simpan type CHOST, CFLAGS & CXXFLAGS di Notepad.
Untuk memudahkan proses selanjutnya adalah me-remote PC Proxy Server dari PC lain dalam satu jaringan, menggunakan WINSCP dan PUTTY. Jika belum punya silahkan download DISINI.
Install WINSCP dan PUTTY
Buka WINSCP, pada Hostname masukkan IP Address PC Proxy Server 192.168.11.11, pada User masukkan ‘root’ (tanpa tanda petik) dan pada Password isikan ‘anjelanet’ (tanpa tanda petik). Untuk memudahkan proses, pilih ‘Save’ kemudian pilih ‘Login’. Jika muncul pilihan, pilih ‘Yes’ atau ‘Update’
Setelah Login WINSCP, pada toolbarnya ada pilihan ‘Open session in PUTTY’, pilih saja untuk membuka PUTTY, atau bisa juga dengan menekan Ctrl+P.
Pada Login PUTTY, masukkan Password ‘anjelanet’ (tanpa tanda petik)
Sekarang anda telah masuk dalam Login PUTTY, untuk melakukan proses Update terhadap PC Proxy Server sebagai tahap berikutnya.
Pada PUTTY, masukkan perintah berikut ini satu per satu, (Jika nanti pada proses updating terdapat pilihan ‘Y/N’ pilih ‘Y’ dan Enter) :

sudo apt-get update
sudo apt-get install squid
sudo apt-get install squid squidclient squid-cgi
sudo apt-get install gcc
sudo apt-get install build-essential
sudo apt-get install sharutils
sudo apt-get install ccze
sudo apt-get install libzip-dev
sudo apt-get install automake1.9
sudo apt-get install acpid
sudo apt-get install multitail

Setelah selesai Proses updating, langkah berikutnya dari PUTTY download file LUSCA_FMI (Credit To NEO FMI), masukkan perintah berikut ini :

wget http://anjelanet.googlecode.com/files/LUSCA_FMI.tar.gz

Selesai proses download, masukkan perintah :

tar xzvf LUSCA_FMI.tar.gz

kemudian :

cd LUSCA_FMI/

Jika anda menggunakan Ubuntu Server 64/bit, masukkan perintah :

make distclean

Proses Compile (Buka Notepad hasil CHOST, CFLAGS & CXXFLAGS tadi :
- Untuk Ubuntu 32/bit :
1. Masukkan CHOST anda, tekan enter
2. Masukkan CFLAGS anda , tekan enter
3. Masukkan CXXFLAGS anda, tekan enter
4. Masukkan kode Compile berikut ini :

./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid \
--localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs \
--enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp \
--enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files \
--enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536

Tekan Enter

- Untuk Ubuntu 64/bit :
1. Masukkan CHOST anda, tekan enter
2. Masukkan CFLAGS anda, tekan enter
3. Masukkan CXXFLAGS anda, tekan enter
4. Masukkan kode Compile berikut ini :

./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid \
--localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs \
--enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp \
--enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files \
--enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536
Tekan Enter

Selanjutnya masukkan berikut :

make

dan berikutnya :

sudo make install

Dari WINSCP copy paste file Squid.conf, Storeurl, Squid, & sysctl : (INGAT PADA WINSCP SISI KIRI ADALAH KOMPUTER YG DIPAKAI UNTUK PROSES REMOTE & SISI KANAN WINSCP ADALAH KOMPUTER PROXY SERVER YANG DIREMOTE)

- File sysctl.pl Copy & Paste ke Directory /etc/
- File squid.conf & storeurl ke Directory /etc/squid/
- File squid ke Directory /etc/init.d/

Kemudian pada buka file squid.conf pada Directory /etc/squid/ yang di copy paste tadi, edit dan sesuaikan bagian ini :

cache_dir aufs /cache1 27300 64 256
cache_dir aufs /cache2 27300 64 256
cache_dir aufs /cache3 27300 64 256

cache_dir aufs /cache1, cache_dir aufs /cache2, cache_dir aufs /cache3 menunjukkan partisi HDD yang akan difungsikan untuk menyimpan cache.

Sesuaikan ‘IP Address Network Mikrotik’ anda, (Ingat bukan IP Address Mikrotik & IP Address Gateway Mikrotik)

acl localnet src 192.168.1.0/24

INGAT!!!!
KESALAHAN PADA cache_dir & acl localnet ‘squid.conf’, MENYEBABKAN ANDA TIDAK DAPAT MENYELESAIKAN PROSES SELANJUTNYA, SEHINGGA MUNCUL PESAN ‘FATAL BUNGLED LINE……’
JADI PERHATIKAN BAIK-BAIK ‘squid.conf’ ANDA.

Selanjutnya kita memberikan Permission untuk Folder Directory Cache, ketikan perintah :

chown proxy:proxy /cache
chmod 777 /cache
chown proxy:proxy /etc/squid/storeurl.pl
chmod 777 /etc/squid/storeurl.pl

karena saya menggunakan Tiga Directory cache, maka perintah yang saya masukkan adalah :

chown proxy:proxy /cache1
chown proxy:proxy /cache2
chown proxy:proxy /cache3
chmod 777 /cache1
chmod 777 /cache2
chmod 777 /cache3
chown proxy:proxy /etc/squid/storeurl.pl
chmod 777 /etc/squid/storeurl.pl

Berikutnya folder-folder swap/cache di dalam folder cache ditentukan dengan perintah :

squid -f /etc/squid/squid.conf -z

Selesai Proses Installasi LUSCA_FMI dengan Squid Proxy High Performance, perintahkan untuk reboot squid anda dengan memasukkan perintah :

sudo /etc/init.d/squid restart

Terakhir, reboot PC Ubuntu Proxy Server anda dengan perintah :

Reboot -h now

Jika Anda Mengikuti Step By Step Proses Instalasi Di Atas Maka Untuk Mematikan PC Ubuntu Proxy Server Anda, Cukup Dengan Menekan Tombol Power PC Ubuntu Proxy Server Anda (Jangan Ditahan, Cukup Tekan Sekali Dalam Hitungan Detik), dimana anda sudah menginstall tools ACPID dengan perintah ‘sudo apt-get install acpid’.

Selanjutnya adalah mengaktifkan PC Proxy sebagai ‘Server Cache’ untuk komputer2 yang lain. Caranya setting mikrotik dari Winbox. Dari Terminal ketik berikut :

/ip fi addr
add name=Local address=192.168.1.0/24
add name=Proxy address=192.168.11.0/24

/ip fi nat
add chain=dstnat action=dst-nat to-addresses=192.168.11.11 to-ports=3128 protocol=tcp \
src-address-list=Local dst-address-list=!Proxy in-interface=Local \
dst-port=80,81,8080,3128 commet="TRANSPARENT PROXY"

add chain=srcnat action=masquerade out-interface=pppoe-speedy1 comment="MASQUARADE"
add chain=srcnat action=masquerade out-interface=Modem

add chain=dstnat action=redirect to-ports=53 protocol=udp dst-port=53 comment="DNS"
add chain=dstnat action=redirect to-ports=53 protocol=tcp dst-port=53

add chain=dstnat action=dst-nat to-addresses=192.168.11.11 to-ports=22 protocol=tcp \
in-interface=pppoe-speedy1 dst-port=22 comment="DMZ"
add chain=dstnat action=dst-nat to-addresses=192.168.3.1 to-ports=80 protocol=tcp \
in-interface=pppoe-speedy1 dst-port=8181

/ip fi addr
add name=Local address=192.168.1.0/24
add name=Proxy address=192.168.11.0/24

/ip fi ma
add chain=forward action=mark-connection new-connection-mark="HIT" passthrough=yes \
protocol=tcp in-interface=Proxy out-interface=Local src-port=3128 dscp=12 comment="PROXY-HIT"

Keterangan :
!Proxy = Membaca IP address Proxy di IP-Firewall-IP Address List
Local = Interface mikrotik yang mengarah ke jaringan Lokal
pppoe-speedy1 = Interface mikrotik yang mengarah ke jaringan internet
Modem = Interface mikrotik yang mengarah ke modem bridge’

‘SESUAIKAN DENGAN KONDISI JARINGAN ANDA’

Sampai disini, anda telah berhasil membangun jaringan dengan menggunakan proxy server sendiri. Selanjutnya tinggal mengembangkan script pada Routerboard/mikrotik untuk pengaturan Mangle dan Bandwidth Management pada opsi ‘Queue’. Tutorial mengenai hal tersebut sudah sangat banyak sekali di internet.

Re: Ubuntu Server 11.04 + Proxy Lusca

husnixs wrote:

Setelah selesai Proses updating, langkah berikutnya dari PUTTY download file LUSCA_FMI (Credit To NEO FMI), masukkan perintah berikut ini :

wget http://anjelanet.googlecode.com/files/LUSCA_FMI.tar.gz

saya heran, Lusca banyak dibilang dari FMI (Forum Mikrotik Indonesia) hanya rename file-nya aja, padahal code-nya sama saja gak ada perubahaan dan bisa di download di http://code.google.com/p/lusca-cache/downloads/list yg merupakan link resmi dari Lusca-nya...

bahkan di link resminya dah ada versi terbaru yg stable tuh...

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Ubuntu Server 11.04 + Proxy Lusca

gan link file nya .....mana....

- File sysctl.pl Copy & Paste ke Directory /etc/
- File squid.conf & storeurl ke Directory /etc/squid/
- File squid ke Directory /etc/init.d/

kalu ga ada file yang di atas sama aja ga terlesaikan juga tuh....


THANK'S

Re: Ubuntu Server 11.04 + Proxy Lusca

saya sudah selesai menginstal ubuntu 11.04 + lusca head.
setelah restart pc pada menu user login menjadi ada 2, pertama user admin yang kedua squid admin.
yang menjadi masalah adalah login user squid diminta memasukkan password, sedangkan pada saat instalasi squid saya tidak merasa memasukkan password.

mohon bantuannya bagaimana caranya agar saya bisa mengetahui password login user squid.


terima kasih

Re: Ubuntu Server 11.04 + Proxy Lusca

kok youtubenya TCP_NEGATIVE_HIT/204 yah?

Re: Ubuntu Server 11.04 + Proxy Lusca

kalo untuk mengembalikan setinganinternet ke mikrotik gimana ya?
jadi gambaran umum jaringannya modem - mikrotik - pc proxy.
kalo mau menjalankan koneksi tanpa melalui pc proxy gimana ya?
selama ini koneksi jalan melalui pc proxy.
tanpa pc proxy jalan untuk ping tapi browsing gak mau jalan.

Re: Ubuntu Server 11.04 + Proxy Lusca

mohon bantuannya ya para senior

saya menggunakan mikrotik pc router dengan 2LAN dan proxy squid 1LAN

Modem -------------- Mikrotik --------- HUB -------- client
                                                        |
                                                        |
                                              proxy Ubuntu

modem = 192.168.0.1

Mikrotik = 192.168.1.254

Proxy = 192.168.1.2

proses install proxy berhasil sesuai dgn tutorial mas husnixs, kalau saya test langsung pake browser mozilla dgn memasukkan ip proxy ke mozilla, buka youtube chachenya tersimpan di proxy,yg menjadi masalahnya setting di Mikrotiknya belom berhasil,soalnya proxy sejajar client,sedangkan tutorial dr mas husnixs proxy sejajar mikrotik, mohon bimbingannya para senior setting di mikrotiknya bagaimana? terima kasih sebelumnya

Re: Ubuntu Server 11.04 + Proxy Lusca

betul tuh mas AthlonII proxy sejajar mikrotik setting di mikrotiknya bagaimana?

Re: Ubuntu Server 11.04 + Proxy Lusca

salam kenal smua mas-mas....maaf masih tahap belajar. tanpa ada yang bimbing hanya melalui mbah google...langsung aja mas-mas
ak da instal ubuntu server ping ok..tp kok ga bsa masuk web clearos
ip add mikrotik da ok
aku pakai 2 speedy 384&1mb, rb750..smentara pakai jasa orang lain..tapi aku blm merasa puas...pakai 9 pc..terima kasih mohon pencerahannya....by kota anggur

Re: Ubuntu Server 11.04 + Proxy Lusca

Newbie ijin nyimak...

Re: Ubuntu Server 11.04 + Proxy Lusca

lagi jalan2 ngeliat ni topik....
mampir dulu dah buat tambah2 wawasan big_smile

Re: Ubuntu Server 11.04 + Proxy Lusca

Squid kan untuk meng-cache website dari internet kalau misalnya content web yang asli di internet berubah otomatis kita cache di proxy kita juga harus menyesuaikan content yang baru tersebut. Pertanyaannya bagaimana cara menghapus atau meng-update website yang sudah kadaluarsa tersebut. Terima kasih....

Firdaus Firdian

Re: Ubuntu Server 11.04 + Proxy Lusca

rheinsnet2000 wrote:

salam kenal smua mas-mas....maaf masih tahap belajar. tanpa ada yang bimbing hanya melalui mbah google...langsung aja mas-mas
ak da instal ubuntu server ping ok..tp kok ga bsa masuk web clearos
ip add mikrotik da ok

ubuntu server yah ubuntu server, beda dengan clearos...
ubuntu server yah gak ada web-gui nya seperti clearos.

rheinsnet2000 wrote:

aku pakai 2 speedy 384&1mb, rb750..smentara pakai jasa orang lain..tapi aku blm merasa puas...pakai 9 pc..terima kasih mohon pencerahannya....by kota anggur

2 line pakai 1 buah RB? bisa sih bisa tapi gak bakal bisa maksimal...
sedangkan 9 pc kenapa pakai 2 line sih? langsung pakai 1 line saja yg 2mbps udah jauh lebih cukup, sebenernya sih 1mbps cukup untuk 9pc tapi terlalu nge-pas banget sih namun klo pakai proxy sih bisa tuh...

maaf promosi dulu, sudah cobain jasa setting yg ini belum? >>> http://www.kaskus.co.id/thread/00000000 … u--company

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Ubuntu Server 11.04 + Proxy Lusca

firdian_cavalera wrote:

Squid kan untuk meng-cache website dari internet kalau misalnya content web yang asli di internet berubah otomatis kita cache di proxy kita juga harus menyesuaikan content yang baru tersebut. Pertanyaannya bagaimana cara menghapus atau meng-update website yang sudah kadaluarsa tersebut. Terima kasih....

otomatis update sendiri koq klo kondisi inet-nya bagus...

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Ubuntu Server 11.04 + Proxy Lusca

AthlonII wrote:

mohon bantuannya ya para senior

saya menggunakan mikrotik pc router dengan 2LAN dan proxy squid 1LAN

Modem -------------- Mikrotik --------- HUB -------- client
                                                        |
                                                        |
                                              proxy Ubuntu

modem = 192.168.0.1

Mikrotik = 192.168.1.254

Proxy = 192.168.1.2

proses install proxy berhasil sesuai dgn tutorial mas husnixs, kalau saya test langsung pake browser mozilla dgn memasukkan ip proxy ke mozilla, buka youtube chachenya tersimpan di proxy,yg menjadi masalahnya setting di Mikrotiknya belom berhasil,soalnya proxy sejajar client,sedangkan tutorial dr mas husnixs proxy sejajar mikrotik, mohon bimbingannya para senior setting di mikrotiknya bagaimana? terima kasih sebelumnya

tidak rekomen topology seperti itu...

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Ubuntu Server 11.04 + Proxy Lusca

2 line pakai 1 buah RB? bisa sih bisa tapi gak bakal bisa maksimal...
sedangkan 9 pc kenapa pakai 2 line sih? langsung pakai 1 line saja yg 2mbps udah jauh lebih cukup, sebenernya sih 1mbps cukup untuk 9pc tapi terlalu nge-pas banget sih namun klo pakai proxy sih bisa tuh...



mas saya mau nanya nih, saya kan mau buka wanet dengan 20 client rencana nya saya mau pakai 2 line speedy yaitu paket 3 mb & 2 mb + mikrotik satu pcs + proxy server satu pcs, bagus tak seperti itu mas...? soalnya saya khawatir dengan 2 line speedy yg mau saya pakai itu nanti nya tidak bisa bekerja secara maksimal seperti coment nya mas opik diatas, kalau kurang bagus seperti rencana saya tsb bagus nya saya harus gimana...? harus ambil paket berapa saja dan harus pakai mikrotik berapa biji mas untuk 20 client tsb, mohon dijawab ya mas soalnya saya benar2 tak ngerti masalah gituan mas sekian terima kasih

Re: Ubuntu Server 11.04 + Proxy Lusca

oh ya masih dengan saya meri, saya masih mau nanya nih mas, teman saya kan nyaranin saya untuk memakai proxy dengan spec sprti ini : core 2 duo, hdd 4 pcs masing2 hdd 80 gb, dan ram nya 4 gb itu bagus tak mas...? soal nya teman saya yg lain dia cuma pakai hdd satu pcs saja tapi iya hdd nya ratusan gb, kira2 bagusan mana mas tuk proxy server makai hdd 80 gb sebanyak 4 pcs atau pakai hdd satu pcs saja dengan kapasitas 300 gb ...? atau kalau ada yg lebih bagus saranin saja yg lebih bagus buat saya mas (warnet saya rencana nya buat 20 client saja mas) n thanks

Re: Ubuntu Server 11.04 + Proxy Lusca

sudah saya  ikuti tutorial yang di berikan masalahnya terjaji eror pada

root@debian:~# /etc/init.d/squid restart
[....] Restarting Squid HTTP proxy: squidFATAL: Bungled squid.conf line 1267: zph_mode
Squid Cache (Version LUSCA_FMI): Terminated abnormally.
failed!

masalah ya di manaya

Mohon bantuan

terima kasih

Re: Ubuntu Server 11.04 + Proxy Lusca

ikut nimbrung, krna permasalahn saya sudah ada yng mempertanyakannya sebelumnya..