Topic: [share] Tuts update ip dinamic ke web

Untuk warnet yang mendapatkan IP public yang dinamis dari provider dapat menggunakan cara ini sebagai alternatif dari metode yang menggunakan dyndns.

Beberapa parameter pada script dimikrotik router dari tutorial asli tidak dapat berjalan pada router saya dan dari keterbasan akan pengetahuan scripting akhirnya selama beberapa malam begadang bersama om google cara ini dapat diaplikasikan di routerboard mikrotik saya yang menggunakan provider GSM

Langsung saja step by step nya:

1.    Daftar di web host gratisan (saya menggunakan 000webhost.com untuk tutorial ini)
2.    catat semua info akun di webhost gratisan anda (user name, IP FTP, dsb)
3.    buat file php dengan nama, contoh ipaddress.php yang isinya:

<?php 

 error_reporting (E_ALL ^ E_NOTICE); 
 $agent = $_SERVER['HTTP_USER_AGENT'];
 if (preg_match('/Mikrotik\/3\.x Fetch/',$agent)){

    $Data = $_GET["ip"];

    if (preg_match( "/^(([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]).){3}([1-9]?[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$/", 

    $Data)) {

         $File = "ipaddress.html"; 
         $Handle = fopen($File, 'w');
         fwrite($Handle, $Data); 
         print "Data Written"; 
         Print $agent;
         fclose($Handle); 
    }
}
?>

4.    upload file tersebut ke public_foldernya webhost anda (bisa menggunakan filezilla untuk proses upload file php tadi)

5.    Tambahkan script pada mikrotik router yang isinya dan jangan lupa sesuaikan interface-ip-dinamis dan nama domain dengan kondisi ditempat masing-masing:

:global ipaddress [/ip address get [find interface="interface-ip-dinamis"] address];

:for i from=( [:len $ipaddress] - 1) to=0 do={:if ( [:pick $ipaddress $i] = "/") do={:set ipaddress [:pick $ipaddress 0 $i];}}

/tool fetch url="http:/domain-anda/ipaddress.php\?ip=$ipaddress" mode=http;

:delay 15;

#hapus file yang terbentuk dari update ip dinamis
#boleh tidak ditambahkan dulu untuk pengecekan apakah script berjalan dengan #baik
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] "ipaddress.php"]]!="nil") do={/file remove $i}}

6.    Buat Scheduler, terserah per-berapa jam ato menit

[rizal@tutuyan] > system sched pri
Flags: X - disabled 
 #   NAME                      START-DATE  START-TIME  INTERVAL  ON-EVENT      RUN-COUNT
 0   ip-dinamis                             startup      1h      dynamic           4 
[rizal@tutuyan] > 

7.    file ip dinamis akan terbentuk pada http://domain-anda/ipaddress.html

Selamat Mencoba smile

smile

Re: [share] Tuts update ip dinamic ke web

wah saya kira ini IP komputer maksudnya.

Dapatkan beragam tips & artikel sewa kantor murah di Jakarta hanya di blog Wins-Property.

Re: [share] Tuts update ip dinamic ke web

wah thanks ya mas, nice share, izin bookmark ya

Kamera CCTV dari Andalan Sekurindo saat ini mulai banyak digunakan berbagai perusahaan besar di Indonesia