Re: Tutorial Failover Mikrotik dan External Proxy

misi om..
mau tanya,, kira2 tuk external proxy, bagusan pake distro apa yah? roll

Re: Tutorial Failover Mikrotik dan External Proxy

wah,.ilmunya bener bener dalem nih mas,., mantap " jadi ngiri nih kepengen sepertoi mas opik,. smile "thanks infonya mas"  untuk private gimana tuh mas.. hehee

Re: Tutorial Failover Mikrotik dan External Proxy

ditempat ku kalo browsernya diset proxy manual bisa, tapi kalo redirect dari mikrotik jadi ga bisa. kalo para suhu ada yang pernah pengalaman kira-kira karena apanya ya?

Re: Tutorial Failover Mikrotik dan External Proxy

mantaaba wrote:

ditempat ku kalo browsernya diset proxy manual bisa, tapi kalo redirect dari mikrotik jadi ga bisa. kalo para suhu ada yang pernah pengalaman kira-kira karena apanya ya?

bagaimana dengan ACL atau default gateway di server yg ditanam proxy?

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Tutorial Failover Mikrotik dan External Proxy

opikdesign wrote:
mantaaba wrote:

ditempat ku kalo browsernya diset proxy manual bisa, tapi kalo redirect dari mikrotik jadi ga bisa. kalo para suhu ada yang pernah pengalaman kira-kira karena apanya ya?

bagaimana dengan ACL atau default gateway di server yg ditanam proxy?

AlhamduliLlla, terimakasih bang Opick, sekarang udah bisa. warnet dan Hotspot sudah jalan lancar + hemat energi

Semoga Amal bang Opick ini mejnadi berkah karena sudah menolong orang kecil seperti saya

hehehehehe...

Re: Tutorial Failover Mikrotik dan External Proxy

saya hanya menyederhanakan script "kecil" nya bang opik cuma buat service squid yang entah tiba² squid stop, error sendiri, coba direstart  juga tetep error, akhirnya harus reboot cpunya, di tempat saya script ini berjalan normal, mudah²an bermanfaat..

#  DIBUAT OLEH OPiKdesign EMAIL th@opikdesign.com
#  DIDEDIKASIKAN UNTUK KOMUNITAS INDONESIA OPENSOURCE
# cek squid
log='daemon.log';
reboot='reboot';
squid="squid";
squid_stop='/etc/init.d/squid stop';
squid_start='/etc/init.d/squid start';
#if ps -Af|grep -v grep|grep $squid;
if pgrep squid;
    # tidak melakukan logging pada aplikasi yang masih berjalan normal - agar berkas log tidak cepat membesar
    then echo "$('date') squid masih berjalan normal"
    # coba restart squid...
    else echo "$('date') squid berhenti dan coba di-restart" >> $log;
    echo "$('date') squid berhenti, Reload..";
    $squid_stop; 
    sleep 12;
    $squid_start
    sleep 3;
    if pgrep squid;
        then echo "$('date') Squid Berhasil Di Reload.." >> $log
        echo "$('date') Done!, Squid Running.. "
        # bila gagal restart...
        else echo "$('date') Squid error & Tray reboot " >> $log;
        $reboot;
        # untuk penggunaan lebih lanjut silahkan dikembangkan lagi...
    fi;
fi;

Re: Tutorial Failover Mikrotik dan External Proxy

andriboi wrote:

misi om..
mau tanya,, kira2 tuk external proxy, bagusan pake distro apa yah? roll

Pake distro turunan debian. My Recomended : Ubuntu Latest Version yg 64bit (kalo support) smile

83 (edited by pandak 19-06-2012 15:25:09)

Re: Tutorial Failover Mikrotik dan External Proxy

@ cybernet.sidareja

bisa dijelaskan lagi tentang script tersebut, apa di jadwal dengan crontab?
terima kasih,

Re: Tutorial Failover Mikrotik dan External Proxy

Siang smua...mohon maap saya member baru mo tanya2 disini mohon petunjuknya.

Saya meredirect mikrotik ke eksternal proxy dan untuk traffic HTTP bisa lewat dan normal, namun masalahnya adalah untuk site HTTPS selalu tidak bisa terbuka...kira2 ada salah dimana yah? mohon solusinya

Re: Tutorial Failover Mikrotik dan External Proxy

ineb wrote:

Siang smua...mohon maap saya member baru mo tanya2 disini mohon petunjuknya.

Saya meredirect mikrotik ke eksternal proxy dan untuk traffic HTTP bisa lewat dan normal, namun masalahnya adalah untuk site HTTPS selalu tidak bisa terbuka...kira2 ada salah dimana yah? mohon solusinya

ini kayaknya dari forum sebelah nih...

HTTPS itu tidak dianjurkan di redirect,
jadi yah HTTPS jgn di redirect ke proxy.

Facebook OPiKdesign
http://badge.facebook.com/badge/100000147194199.279.411965916.png
* IT Consultant * Networking Specialist for Internet Cafe/HotSpot/SOHO * Maintenance * Graphic & Web Design, 3D Modeling & 2D/3D Animation * Hosting & Domain * email to: th@opikdesign.com

Re: Tutorial Failover Mikrotik dan External Proxy

@ opikdesign atau teman2 yang lain

mohon petunjuk/penjelasannya tentang script yang di share oleh cybernet.sidareja, apakah perlu diset jadwalnya lewat crontab?atau gmn ya?masih bingung hehehe
thx b4

87 (edited by cybernet.sidareja 21-09-2012 18:01:47)

Re: Tutorial Failover Mikrotik dan External Proxy

@pandak
iya betul jalaninya pakai crontab simple aja mas ga usah bingung, ikutin aja caranya sama dg punya @ichalssy ganti isinya doang
nama file saya daemon.sh
trus di chmod +x daemon.sh
tes manual scriptnya:
./daemon.sh
nanti hasilnya kurang lebih begini :
675
Fri Sep 21 17:55:04 WIT 2012 squid masih berjalan normal

kalau sperti itu berarti sukses , lalu pasang di crontab,
crontab -e
contoh isi crontab saya
# m h  dom mon dow   command
*/3 * * * * /root/daemon.sh
udah finish, good luck!
* dsaya pakainya ubuntu squid lusca smile

Re: Tutorial Failover Mikrotik dan External Proxy

mas opick klo dipasangin cntlm rule fail-over proxynya ga mau jalan. mohon pencerahan big_smile

Re: Tutorial Failover Mikrotik dan External Proxy

Bang opic  tutorial ini sangat bermanfaat, bolehkah saya link ke web saya

Re: Tutorial Failover Mikrotik dan External Proxy

sudah dicoba......
jalan... mantap bener
makasih ilmunya bos.........

Re: Tutorial Failover Mikrotik dan External Proxy

mohon saya numpang tanya disini , saya liat liat pemahaman tentang mikrotiknya udah pada jago ,
saya setting mikrotik RB450 di winbox ,. lemot nya minta ampun . jadi saya butuh waktu lama untuk settingnya . ada yang tau solusinya ? , atau ada yang tau penyebabnya ?
makasih mohon bantuaanya

Re: Tutorial Failover Mikrotik dan External Proxy

salam master² saya mau tanya saya pake mikrotik RB-951 saya kombinasikan dengan proxy external ubuntu 12.04....


topologi

modem (bridge) --------mikrotik----------swith------client
                                         |
                                         |
                                    proxy(ubuntu)
ip
modem :192.168.1.1

mikrotik : ke modem :192.168.1.2
                ke client : 192.168.0.254
                ke proxy : 192.168.3.1

ubuntu : ke mikrotik : 192.168.3.2
              ke client  : 192.168.0.253


untuk proxy saya fungsikan 2 untuk proxy dengan samba server dengan topologi eth0 = proxy dan eth1= samba...


saya mau tanya kenapa saat saya nat ke proxy malah ga bisa browsing?????apakah pengaruh saya buat proxy untuk samba juga???/mohon pencerahan..

Re: Tutorial Failover Mikrotik dan External Proxy

bingung gan pelajarinnya..... harus ada yang bimbing ni

Re: Tutorial Failover Mikrotik dan External Proxy

para Master-master
bisa minta tolong

/ip firewall mangle
add action=add-src-to-address-list address-list="wifi hot-spot" \
    address-list-timeout=1m chain=prerouting \
    comment="User online list adding from HotSpot" disabled=no \
    in-interface=to_wifi src-address=192.168.2.0/24 \
    src-address-type=!local
add action=add-src-to-address-list address-list="warnet" \
    address-list-timeout=1m chain=prerouting \
    comment="User online list adding from Warnet" disabled=no \
    in-interface=to_warnet src-address=192.168.1.0/24 \
    src-address-type=!local
/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect_Proxy_Warnet" \
    disabled=no dst-port=80,3128 in-interface=to_warnet \
    protocol=tcp src-address-list=warnet \
    to-addresses=192.168.3.253 to-ports=3128
add action=dst-nat chain=dstnat comment="Redirect_Proxy_WiFi" \
    disabled=no dst-port=80,3128 in-interface=to_wifi \
    protocol=tcp src-address-list="wifi hot-spot" \
    to-addresses=192.168.3.253 to-ports=3128

Kalau memasukkannya lewat winbox gimana ya???
coz src-address-type=!local
di winbox tanda ! nya gak ada

Mohon pencerahannya

Re: Tutorial Failover Mikrotik dan External Proxy

*** RADENPOKER ***
AGEN POKER TERPERCAYA di INDONESIA
BONUS DEPOSIT NEW MEMBER 15%
BONUS NEXT DEPOSIT 10%
BONUS TURNOVER 0.5%
REFERRAL 15%
YM : groupraden @yahoo.com
whatsapp :+85598307890
PIN BB :593DD9A9 / 5C1406C6
Atau melalui livechat
1 ID BISA MAEN 5 GAME
**POKER,Q-KICK,CEME,BLAKCJACK, CAPSA SUSUN**
PEMAEN BISA JADI BANDAR DI DALAM GAME TERSEBUT
Website kami : radenpoker.com
Alternative link: radenpoker.net

Re: Tutorial Failover Mikrotik dan External Proxy

tutorialnya sangat jelas dan mudah dimengerti.. terimakasih