OpenWRT: 3G modem

From SpeedyWiki

Jump to: navigation, search

Contents

[edit] Pastikan di Make Menuconfig

Network >
	chat
	ppp
		ppp-mod-pppoa
		ppp-mod-pppoe
		ppp-mod-pppol2tp
		ppp-mod-pptp  
		ppp-mod-radius
	ppp-multilink
		pppdump 
		pppstats
Kernel Modules > USB Support >
   kmod-usb-serial
        kmod-usb-serial-ipw
        kmod-usb-serial-option
        kmod-usb-serial-qualcomm
        kmod-usb-serial-wwan
   kmod-usb-acm
LuCI >
      6. Protocols >
	 luci-proto-3g

[edit] Instalasi

Masukan USB modem & Restart Router. Cek dmesg melalui shell ketik

dmesg

akan ada kata-kata seperti,

[   18.140000] USB Serial support registered for GSM modem (1-port)
[   18.150000] usbcore: registered new interface driver option
[   18.150000] option: v0.7.2:USB Driver for GSM modems
[   18.270000] USB Serial support registered for Qualcomm USB modem
[   18.280000] usbcore: registered new interface driver qcserial
[   24.540000] usb 1-1: new high-speed USB device number 3 using ehci-platform
[   24.710000] option 1-1:1.0: GSM modem (1-port) converter detected
[   24.710000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0 
[   24.720000] option 1-1:1.1: GSM modem (1-port) converter detected
[   24.730000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[   25.750000] scsi 3:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[   25.760000] scsi 4:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
[   18.140000] USB Serial support registered for GSM modem (1-port)
[   18.150000] usbcore: registered new interface driver option
[   18.150000] option: v0.7.2:USB Driver for GSM modems
[   18.270000] USB Serial support registered for Qualcomm USB modem
[   18.280000] usbcore: registered new interface driver qcserial
[   24.540000] usb 1-1: new high-speed USB device number 3 using ehci-platform
[   24.710000] option 1-1:1.0: GSM modem (1-port) converter detected
[   24.710000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[   24.720000] option 1-1:1.1: GSM modem (1-port) converter detected
[   24.730000] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1 

Kita juga dapat melakukan

cat /proc/bus/usb/devices

Keluar kata-kata kurang lebih

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1003 Rev= 0.00
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile

Cek /dev/ttyUSB*

ls /dev/ttyUSB*

Akan keluar misalnya

/dev/ttyUSB0  /dev/ttyUSB1

Salah satu diantaranya adalah USB modem yang kita pasang.

[edit] Konfigurasi USB Modem

Edit

vi /etc/config/network

Contoh untuk XL

config interface 3g
   option ifname ppp0
   # option pincode 1234
   option device /dev/ttyUSB0
   # option apn your.apn
   option apn internet
   option service umts
   option proto 3g

Contoh untuk Telkomsel

config interface '3G'                 
   option proto '3g'            
   option service 'umts'        
   option device '/dev/ttyUSB0' 
   option apn 'telkomsel'       
   option username 'wap'        
   option password 'wap123'

Untuk IPv6 sebaiknya konfigurasi sambungan Telkomsel pakai

config interface '3G'                 
   option proto '3g'            
   option service 'umts'        
   option device '/dev/ttyUSB0' 
   option apn 'internet'       
   option username         
   option password 

Selanjutnya kita dapat me-reboot router. Biasanya akan secara automatis modem 3G terdetek dan akan langsung bisa di aktifkan / digunakan. Kita dapat melihat status-nya di Administration > Network > Interfaces.

[edit] Referensi

[edit] Pranala Menarik

Personal tools